'Are nibtools in Windows x64-version avai'
Author:Pete Rittwage (registered user: 558 posts )
Date: Wed, Feb 29th, 2012 @ 15:59 ( . )

If you compile them yourself, yes. I assure you, if you download the package from Nate's site, they work, and they are 32-bit.


REPLY: [With No Quote] --- [With Quoted Text]

'Are nibtools in Windows x64-version avai'
Author:jabberwookie (registered user: 6 posts )
Date: Thu, Mar 01st, 2012 @ 06:41 ( . )

You are only partly right, Pete. I still have to install the amd64/x64 OpenCBM drivers on an x64 system. But thanks to your suggestion I found out that I have to install 32-bit OpenCBM drivers AS WELL. Then the 32-bit opencbm.dll and its companion DLLs are copied as well, which are required for the 32-bit version of nibtools. ONLY THEN it works on an x64 system! So I installed both opencbm-0.4.99.94-amd64 and opencbm-0.4.99.94-i386. It was the missing 32-bit opencbm.dlls that caused nibtools to show this cryptic error message. Now it works. But still the x64 OpenCBM drivers are necessary. The 32-bit cbm4wdm.sys is not used on an x64 system, as all system drivers need to be 64-bit. Just as Microsoft stated.

But I can't seem to pass plugin-options to the plugin. E.g. when I try to install with "instcbm.exe xa1541 --cabletype=xm1541" the cable type parameter seems to be ignored and the "Driver configuration" only shows that "Cable type" is "auto (-1)". It seems options/parameters are not passed to the plugin. Or just instcbm shows it wrong. Anyway, it works now. Many thanks again to both of you, Pete and Nate. Now I can use latest version of nibtools again :-)


REPLY: [With No Quote] --- [With Quoted Text]


--- 0 Users Online --- 0 Recent Unique Posters

Q63=1657016899 - Threads: / 1657016899